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1 Pansen Repeater Help Index

Pansen Repeter Help Index:
Overview:

Introduction

Menus:
File menu

Edit menu

View menu

COM Port menu

Repeater menu

Base Station menu

Help menu

2 Introduction

2.1 System Overview

Introduction:
System Components

Theory of operation

System Components:

The pansen repeater logging system is designed for autonomous measurements of the body core
temperature and the heart beat of ruminants over an extended time period. The pansen repeater
system contains of the following eight parts:

Implant logger
Repeater collar
Base Station
USB connection cable
LED Check Operation device
Magnet
Graphical User Interface (GUI)
Data statistic evaluation programm

Implant logger:
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The Implant logger or simply implant is meant to be located in the rumina of the animal of interrest. It
measures the animals core temperature in predefined intervalls and sends it wirelessly to the
Repeater collar. Additionally the resting heart rate is measured permanently via an acceleration
sensor and is also reported in predefined intervalls to the Repeater collar (see Implant timing). The
implants operation is started/stopped via a magnet by holding the magnet 2-4 seconds to the marked
position on the ceramic head.

Repeater collar:

The Repeater collar or simply repeater is meant to be located at the neck of the animal of interrest. It
measures the ambient temperature, the activity of the animal via an acceleration sensor and the
position of the head. Data transmitted from the implant is collected by the repeater and saved along
with its measured values into an on board memory. The wireless communication is done in the
433MHz ISM band. The saved data can be read out via the USB connection cable and a
corresponding GUI which is also used for setting up the configuration options of the repeater. A data
gathering and interfacing with the repeater is also possible wirelessly via a Base Station. The repeater
also offers the usage of a HF transmitter with several choosable options for easier location of the
repeater in the field. (see Repeater timing)
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Base Station:

The Base Station or simbly base is aimed for wireless interfacing to a repeater for the purpose of
checking of proper operation and data download (see Interfacing overview ). A scan for repeaters
within communication range can be performed, listing all available repeaters. A monitoring mode for
receiving packets of all implants within communication range is also added to be able to verify the
operation of the implants and for calibration of the temperature measurement (see Base Station
details).

USB connection cable:
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The USB connection cable is used to connect the repeater or the base station to a PC via USB. The
cable incorporates a serial interface emulator to enable the PC to communicatie over a COM port
with the connected device. On plugging the USB cable into a USB port on the PC an automatic
installation of the serial COM drivers is performed. The other end of the cable has a custom
connector with a mechanic polarity protection that can be connected either to a repeater or a base
station (see Interfacing overview ).

LED Check Operation device:

The LED Check Operation device is used in the field to have a means of quick checking the
operation of the repeater and indirectly the wireless connection to the implant before freeing the
animal after successful installation of the system. For this purpose the device is connected to the
repeater via the connector used for interfacing with the PC (see Interfacing overview ). The LED
blink timing indicates the status of the repeater (see LED Check Operation device behavior).

Magnet:

A magnet is used for turning on and off the implant or the repeater if a PC access is not suitable e.g.
in the field to avoid extra baggage (e.g. LapTop). To turn the repeater on or off you have to hold the
magnet to the respective marking on the devices chassis for two the four seconds.
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Graphical User Interface (GUI):

The GUI is the application running on your computer which is used as the interface for users to
connect directly to a repeater or a base station.

Data statistic evaluation programm:

At the end of a logging session the gathered data is read out via the GUI and must be post
processed by a statistics programm which is available online at the FIWI. For this pupose the data
must be uploaded to the server and the evaluation programm will perform a statistical reduction of
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the data leaving only valid data that can be downloaded as a .csv file.

Theory of operation:

Interfacing overview:

Data obtained by the system is saved to memory located on the repeater which can be read out via
the GUI over a cable connection or wirelessly via the base station.

The following figure gives an overview of how the components are interfacing with each other. The
implant which has to be located in the animals rumina retrieves body temperature and heart beat data
and sends it via the wireless 433MHz ISM link to the repeater collar located at the neck of the
animal. The repeater saves this data along with the ambient temperature, the animals activity, the
head position value and the RTC (Real Time Clock) to the on board memory. This data can be read
out via PC and the GUI if connected directly via the USB connection cable to the repeater. While
connected in this way the repeater settings can also be retrieved and changed and the saved packets
can be visualized at runtime to check proper operation.

Synchronization:

Implant timing of data packets:
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The implant has an unique ID which is also part of every data packet transmitted. This ID is used to
avoid the repeater logging data from implants with different implant IDs, for this purpose the implant
ID the repeater should log to can be selected via the Logger Settings Dialog. To save battery power
and thereby prolonging the systems run time,  data transmission is only done in predefined intervalls
so called Log Intervals. These intervalls are dictated by the implant in use and can not be changed
after purchasing. Therefore the logging intervall as shown in figure below which can be choosen in
multiples of 15 seconds should be determined before ordering implant hardware. The body
temperature is sent via a dedicated BT packet to the repeater during every intervall, measurement of
the heart beat can be performed in every intervall and sent in separate HB packets to the repeater as
shown in the third timing example of figure below. But you can also choose to skip the heart beat
measurement for a selectable number of intervalls, this gives a HB interval in multiples of the Log
Interval as shown in the first two timing examples in figure below. On purchasing of an implant the
implant ID, Log interval and HB interval can be selected by the user and set accordingly by the
manufacturer, keep in mind that these settings can not be changed by the user anymore.

 

Repeater synchronization:

The operation of the base station is basically to be in a low power state most of the time, in below
figures referred to as sleep, and just wake up for a few 100ms to receive the data packets
transmitted by the implant. After reception of the last data packet of an interval the repeater searches
for a base station in communication range to offer a means of reading out status information and
download data remotely via a base station. To achieve propper operation the implant and the
repeater must be synchronized in time that the repeater is awake when packets are actually
transmitted by the implant and in the mean time save battery life by switching into a low power
mode. To synchronize the repeater to the implant which is always sending its packets in the same
time interval the repeater checks the ISM frequency on which the implant is sending its data for
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packets with the implant ID which the repeater is configured to synchronize to. This listening mode is
maintained for the duration of one Sync Interval which equals one Log Interval if no packet with the
set implant ID is received at all, and it is started at every start of a repeater logging session. It is
recommended to start the implant first and afterwards the repeater to achieve a synchronization with
the first synchronization cycle. Below figure shows the timing diagram after a turn on logging event of
a repeater and how the repeater synchronizes with the implant. The start of a logging session of the
repeater can be initiated via the GUI or by using the magnet turn on/off routine.

If the synchronization at startup is not successful as shown in figure below the repeater goes into
sleep mode after one Sync Interval. The next ten Log Intervals the repeater tries to receive data
from the implant but since they are not in timely synchronization the repeater will not receive any
packet at all. After these ten intervals an additional synchronization intervall is started where the
repeater can establish synchronization again which succeeds in figure below. If this synchronization
would not succeed during this additional sync interval the repeater would go to sleep and start from
the beginning with ten Log Intervals with no packets at all followed by another synchronization
interval a.s.o. If for some reason an already synchronized repeater does not receive any packets
from the implant in ten consecutive Log Intervals the synchronization would also be started and
would behave like at the beginning of a repeater logging session.

The data received from the implant is saved to an on board memory and can be read out via the
supplied USB cable (see USB connection cable).  Apart of the received data the repeater is also
measuring the ambient temperature, the activity of the animal, a head position value and is saving all
data every logging intervall along with the on board RTC (Real Time Clock) to the on board
memory.  To be able to find the repeater more easily a HF transmitter is used which on/off times can
be set via the GUI. It offers the user a selection to set daily transmit times, monthly transmit days and
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yearly transmit months that are user configurable and for the purpose of saving battery live (see VHF
Settings).

Base Station details:

The task of the base station is basically to offer the user the opportunity to read out the current status
of the repeater or download the logged data remotely i.e. about 100m maximum free field
communication distance. Since the repeater is not accessible via the ISM link most of the time
because it is in a low power mode to save battery life as discussed in Repeater synchronization, the
base station is not able to initiate a communication to the repeater by itself. Therfore rather the
repeater is implemented to initiate the communication to the base station by sending out a base
station request at the end of every wake up after retreiving data from the implant has ended. Due to
this strategy it is not possible to read out the repeater settings via the base station immediately upon
request i.e. clicking the read button and getting the data response immediately. A click of the read
button rather sends the base station into a listen mode where it waits for the base station to send a
connection request packet which can take up to one Log Interval. The request packet contains the
implant ID to be able to distiguish requests from different repeaters. The user has the possibility to
pick the implant ID of the animal where data should be retrieved from via the GUI (see Implant ID
Picker). This request is acknowledged when the connection request packet has the user selected
implant ID. In this case communication is established and data can be retreived. If no packet with
corresponding implant ID is received the base station stays in receive mode indefinitely, this can be
the case if the repeater is out of range and no communication is possible. To check which repeaters
are in connection range the user can listen to all repeaters irrespective of the implant ID and display
them on the screen (see Loggers in vicinity group).

LED Check Operation device behavior:

This device is meant to have an easy and quick way of verifying whether the repeater is started
correctly and whether it is synchronized with the implant. For this purpose you have to connect the
LED Checker to the repeater via the communication interface connector. If the repeater logging is
not started jet the led will be off. After enabling the repeater logging either via magnet or GUI the
LED will blink every 2 seconds. When the repeater succeeds in synchronizing with the implant the
LED will blink every 1 second.

3 Menus

3.1 File menu commands

File menu commands

The File menu offers the following commands:

New Creates a new document.

Open Opens an existing document.



Ruminal Heart Rate Data Logger12

© 2014 VECTRONIC Aerospace GmbH

Close Closes an opened document.

Save Saves an opened document using the same file name.

Save As Saves an opened document to a specified file name.

Print Prints a document.

Print Preview Displays the document on the screen as it would appear printed.

Print Setup Selects a printer and printer connection.

Exit Exits Pansen Repeater.

3.2 Edit menu commands

Edit menu commands

The Edit menu offers the following commands:

Undo Reverse previous editing operation.

Cut Deletes data from the document and moves it to the clipboard.

Copy Copies data from the document to the clipboard.

Paste Pastes data from the clipboard into the document.

3.3 View menu commands

View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.

Status Bar Shows or hides the status bar.

3.4 COM-Port menu commands

COM Port menu commands

The COM Port menu offers the following commands:

Choose COM
Port

Opens the choose COM port dialog.

3.5 Repeater menu commands

Repeater menu commands

The Repeater menu offers the following commands:

Read Data Opens the read data dialog.

Repeater Opens the repeater settings dialog.
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Settings

Erase Memory Opens the erase memory dialog.

Set Head Pos
Threshold

Opens the set head position threshold dialog.

Calibrate
Frequency

Opens the calibrate frequency dialog.

3.6 Base Station menu commands

Base Station menu commands

The Base Station menu offers the following commands:

Read Settings Opens the read settings dialog.

Implant
Surveillance

Opens the implant surveillance dialog.

Read Data Opens the read data dialog.

3.7 Help menu commands

Help menu commands

The Help menu offers the following commands, which provide you assistance with this application:

Help Topics Offers you an index to topics on which you can get help.

About Displays the version number of this application.

4 status bar

Status Bar

The status bar is displayed at the bottom of the Pansen Repeater window. To display or hide the
status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to navigate
through menus. This area similarly shows messages that describe the actions of toolbar buttons as
you press them, before releasing them. If after viewing the description of the toolbar button
command you wish not to execute the command, then release the mouse button while the pointer is
off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator    Description

CAP           The Caps Lock key is latched down.
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NUM         The Num Lock key is latched down.

SCRL         The Scroll Lock key is latched down.

5 toolbar

Toolbar

The toolbar is displayed across the top of the application window, below the menu bar. The toolbar
provides quick mouse access to many tools used in Pansen Repeater,

To hide or display the toolbar, click Toolbar from the View menu.
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